Automatizzare Excel con Somma più Se

In questo articolo vi spiegherò meglio come ottimizzare e automatizzare il nostro file Excel con la funzione Somma Più Se.

Iniziamo con il capire se è la funzione che fa al caso nostro analizzandone il suo funzionamento attraverso la sintassi:

Somma.più.se(intervallo somma, intervallo criteri1, criteri1, ecc.)

Analizziamo ora voce per voce per capire meglio come funziona:

  • Intervallo somma indica la colonna che vorremo andare a sommare nel momento in cui si verifica una determinata condizione
  • Intervallo Criteri1 indica la colonna che conterrà i nostri criteri
  • Criteri1 indica invece il criterio che dovrà essere soddisfatto per far si che avvenga la somma

Esempio semplice Somma.più.se per capirne il funzionamento

Prendiamo un file semplice con tre colonne: Giorno – Mese – Importo ed ipotizziamo di voler calcolare i valori mensili dalla colonna importo in una seconda tabella riassuntiva.

Esempio Tabella Dati

A questo punto ipotizziamo di voler sommare tutti gli importi di Agosto in questa tabella di riepilogo.

La nostra funzione sarà:

=SOMMA.PIÙ.SE(C2:C5;B2:B5;F9)

  • C2:C5 indicherà i valori da sommare
  • B2:B5 indicherà i criteri da testare
  • F9 Indicherà il valore di test
Somma Più Se – Esempio

Se vuoi capire meglio l’esempio puoi scaricare il file dell’esempio sopra descritto.

Ottimizzazioni della funzione Somma.Più.Se

Ovviamente questo è un esempio base per farvi capire il funzionamento, da questo potremmo ottimizzarlo in diversi modi quali:

  • Utilizzo della funzione “Gestione Nomi
  • Aumento dei criteri di Test per restringere il campo di somma