Come usare la funzione Stringa Estrai di Excel

La funzione stringa estrai di Excel ci permette di estrarre da una stringa di caratteri e numeri in un range delimitato.

Per capire come funziona e cosa ci restituirà la funzione stringa estrai è più facile partire da un esempio pratico piuttosto che mettersi ad analizzare la funzione come ce la propone Excel.

Ipotizziamo che la nostra necessità sia di estrarre dalla stringa “Monza20900” la parte numerica.

La funzione stringa.estrai per fornirci il risultato richiesto ha la necessità di avere il punto iniziale e finale della nostra stringa, quindi avremo:

Posizione Iniziale: 6

Numero di Caratteri: 5

La nostra funzione dovrà essere:

stringa.estrai(A1;6;5)

Esempio pratico di Funzione Stringa Estrai con Codice Fiscale

Se il primo esempio è molto teorico, un uso che potrebbe tornarci utile è quello di estrarre anno – mese – giorno dal codice fiscale con la funzione Stringa estrai.

Partiamo da un codice fiscale casuale: DMCGBC79A29Z800M

Sappiamo che l’anno di nascita è rappresentato dal carattere 7 al 8, il mese è il carattere 9 e il giorno dal 10 all’11.

Pertanto sfruttando la funzione troveremo:

Anno: stringa.estrai(a1;7;2)

Mese: stringa.estrai (a1;9;1)

Ovviamente noi abbiamo bisogno che il mese venga trasformato in un numero, per fare questo utilizziamo il cerca.vert per trovare la corrispondenza carattere – mese.

Per fare questo utilizziamo la formula: =+CERCA.VERT(B1;F3:G15;2;FALSO)

Giorno: stringa.estrai(a1;10;2)

L’estrazione però ci fornirà numeri diversi in base se sia uomo o donna, ovvero per le donne il giorno di nascita è aumentato di 40.

Se volessimo trasformarlo nel formato data ci basterà utilizzare la funzione “concatena” così fatta:

concatena(stringa.estrai(a1;7;8);”/”;stringa.estrai (a1;9);”/”;stringa.estrai(a1;10;11))

Related posts